Fehler nach Update von 19.1 auf 19.2

Fragen zur Installation und zu den ersten Schritten mit WaWision
Antworten
andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Fehler nach Update von 19.1 auf 19.2

Beitrag von andrejohn » Fr 20. Sep 2019, 11:50

Hallo Gemeinde, ich habe folgendes Problem:

Xentral 19.1 auf Ubuntu 18.04 LTS in Betrieb genommen, Daten schon mal eingepflegt , da wir uns nächsten Monat vom einem Mitbewerber verabschieden wollen. Da die Zeit nun näher rückt habe ich letzte Woche die Lizenz für den Updateserver erworben. Das Update auf 19.2 wird eingespielt und funktioniert meiner Meinung auf soweit alles. Nun wollte ich Docscan einrichten und siehe da, ein Problem. Ich gehe auf Administration-Einstellungen-Benutzer, die Liste der Benutzer wird aufgebaut, möchte ich nun aber einen Benutzer editieren bzw einen neuen Benutzer anlegen passiert folgendes:

Xentral \ Core \ ErrorHandler \ PhpErrorException
Core Error: <br>The encoded file <b>/var/www/html/www/www/lib/modulliste.php</b> requires a license file <b>key.php</b>.
Unknown:0
2Xentral\Core\ErrorHandler\ErrorHandler→handleError()
/var/www/html/www/classes/Core/ErrorHandler/ErrorHandler.php:53
1Xentral\Core\ErrorHandler\ErrorHandler→onShutdown()

Einen Einrichtungsfehler kann ich fast ausschliessen, ich habe die 19.1 nochmal auf einem weiteren Server blank installiert und sofort das Update gefahren, selbes Problem.
Es lässt sich unter PHP7.2 und 7.3 Reproduzieren.
Über Hilfe wäre ich Dankbar.

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 14:34

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von sauterbe » Mo 23. Sep 2019, 13:57

wie lauten die letzten 4 ziffern der lizenz?
dann kann ich mal schauen ob die korrekt erstellt wurde

andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von andrejohn » Di 24. Sep 2019, 12:41

3834

andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von andrejohn » Di 24. Sep 2019, 12:51

habe nun auf einem anderer Server mit Centos 7.7 Xentral nochmal installiert. Hier wird jedoch automatisch die 19.3 Opensource installiert und der Fehler tritt nicht auf. Wenn ich hier den Schlüssel eingebe wird mir ein Update auf 19.2 angeboten (downgrade?). Versuchshalber mal gemacht, Fehler wieder da.

warum gibt es die 19.3 Opensource zum Download? aber auf dem Ubuntu System kein Update auf 19.3?
Bekomme die Daten ja auch nicht auf den Centos Server kopiert

Grüße

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 14:34

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von sauterbe » So 29. Sep 2019, 16:36

wie lauten die letzten 4 ziffern der lizenz - kann gerne die 19.3 freischalten

andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von andrejohn » Mo 30. Sep 2019, 11:47

steht oben schon :D

die letzten 4 lauten 3834


muss ich jedesmal anfragen wenn ich auf die neue uptaten will? Dachte das funktioniert mit dem updatekey automatisch

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 14:34

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von sauterbe » Fr 4. Okt 2019, 11:38

ich hab die 19.3 freischalten / sie sollte jetzt erscheinen

andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von andrejohn » Di 8. Okt 2019, 08:47

sauterbe hat geschrieben:
Fr 4. Okt 2019, 11:38
ich hab die 19.3 freischalten / sie sollte jetzt erscheinen
hey, ja er zeigt mir das update dann an und lässt es auch installieren. jedoch auch hier lässt sich der Fehler reproduzieren.
möchte ich nach dem Update einen Mitarbeiter editieren:
Xentral \ Core \ ErrorHandler \ PhpErrorException
Core Error: <br>The encoded file <b>/var/www/html/xentral/www/www/lib/modulliste.php</b> requires a license file <b>key.php</b>.
Unknown:0
2Xentral\Core\ErrorHandler\ErrorHandler→handleError()
/var/www/html/xentral/www/classes/Core/ErrorHandler/ErrorHandler.php:53
1Xentral\Core\ErrorHandler\ErrorHandler→onShutdown()
wenn ich die 19.3 direkt installiere habe ich das Problem nicht. lasse ich aber über die bestehende 19.3 das update nochmal fahren entsteht auch hier der Fehler wie beim Update von 19.1 auf 19.2

andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Re: Fehler nach Update von 19.1 auf 19.2

Beitrag von andrejohn » Di 8. Okt 2019, 09:26

Info: Die Vollinstallation hat die Nummer 19.3.5.9340eb, nach dem Update die 19.3.8bcba28
Auf der Startseite unten wird das Update auch nicht angezeigt, nur die aktuelle Versionsnummer. ich weiss absolut nicht wo der Fehler liegen soll

Antworten