Fehler beim Update von 19.2 auf 19.3

Fragen zur Installation und zu den ersten Schritten mit WaWision
Antworten
klsfsthar
Beiträge: 0
Registriert: Do 3. Jan 2019, 22:44

Fehler beim Update von 19.2 auf 19.3

Beitrag von klsfsthar » Do 31. Okt 2019, 16:55

Hallo,

ich habe einen Update von Version 19.2 auf 19.3 vorgenommen danach erscheint folgender Fehler. Software ist nicht mehr nutzbar:

Definition can't be created. "Xentral\Components\Database\Bootstrap::onInitExtendedPdo" is not callable.

Version ist:

SOFTWARE
Xentral-Revision: 19.3.7a1e19a
Xentral-Version: OSS
FPDF-Version: 3

Was kann ich tun?

Vielen Dank

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 14:34

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von sauterbe » Do 31. Okt 2019, 19:34

ist auf dem Server PHP 7.2 installiert?

klsfsthar
Beiträge: 0
Registriert: Do 3. Jan 2019, 22:44

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von klsfsthar » Do 31. Okt 2019, 20:01

Server ist noch auf 5.6. Muss ich hochziehen.

Danke!

klsfsthar
Beiträge: 0
Registriert: Do 3. Jan 2019, 22:44

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von klsfsthar » So 17. Nov 2019, 12:42

Hallo,

ich habe nunmehr eine neue VM mit php 7.3.11 am laufen. Xentral übernommen und laufe weiter nach dem Update von 19.2 auf 19.3 auf den Fehler:

Xentral: Es ist ein unerwarteter Fehler aufgetreten!
Definition can't be created. "Xentral\Components\Database\Bootstrap::onInitExtendedPdo" is not callable.

Xentral \ Core \ DependencyInjection \ Exception \ InvalidArgumentException
Definition can't be created. "Xentral\Components\Database\Bootstrap::onInitExtendedPdo" is not callable.
/opt/bitnami/apache2/htdocs/lmwawip01/classes/Core/DependencyInjection/Definition/FactoryMethodDefinition.php:24

7 Xentral\Core\DependencyInjection\Definition\FactoryMethodDefinition→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/classes/Core/DependencyInjection/ServiceRegistry.php:123

6 Xentral\Core\DependencyInjection\ServiceRegistry→addFactory()
/opt/bitnami/apache2/htdocs/lmwawip01/classes/Core/DependencyInjection/ServiceRegistry.php:132

5 Xentral\Core\DependencyInjection\ServiceRegistry→addFactories()
/opt/bitnami/apache2/htdocs/lmwawip01/classes/bootstrap.php:56

4 →include()
/opt/bitnami/apache2/htdocs/lmwawip01/phpwf/class.application_core.php:119

3 ApplicationCore→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/phpwf/class.application.php:119

2 Application→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/www/eproosystem.php:147

1 erpooSystem→__construct()
/opt/bitnami/apache2/htdocs/lmwawip01/www/index.php:60

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 14:34

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von sauterbe » Do 21. Nov 2019, 15:25

wenn man php 7.2 verwendet? was ist dann

andrejohn
Beiträge: 0
Registriert: Fr 20. Sep 2019, 08:57

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von andrejohn » Do 21. Nov 2019, 16:07

Ich habe es vom ersten Tag an auf 7.3 laufen. Hatte das Problem nicht

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 14:34

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von sauterbe » Di 26. Nov 2019, 13:27

ist im Screenshot links etwas rot oder gelb markiert? Ein PHP Modul das eventuell fehlt?

klsfsthar
Beiträge: 0
Registriert: Do 3. Jan 2019, 22:44

Re: Fehler beim Update von 19.2 auf 19.3

Beitrag von klsfsthar » So 1. Dez 2019, 18:22

Hallo,

habe jetzt 19.3 zum laufen gebracht. Es fehlte die ionCube-Extension für php. ionCube muss bereits vor dem Update verfügbar sein. Dann läuft der Update auch durch.

Antworten